If you're having trouble with the eMCCD or eMCCPD forms, it may be because your system doesn't meet the technical requirements.

Always take note of your tracking number in the top right corner so you can resume a form if you have to close the window.

Browser and system requirements

Browser Version
Microsoft Internet Explorer 9.0
10.0
11.0
Google Chrome Current
Mozilla Firefox Current
Apple Safari Current

Older browsers, such as Microsoft Internet Explorer 8, might not work.

Tablet or smartphones need to be:

  • Microsoft Windows 8.1 devices
  • Apple iPad2 or later, using iOS 5 or later
  • Google Android version 4 or later devices.